# ファイルのオープン - DE Decompiler

> Delphiで記述された、またはC++Builderで作成されたVCLプログラム用の専門家向け逆コンパイラ。リバースエンジニアリングやフォレンジックに向け、Win32/Win64のコード、フォーム、ユニット、クラスを解析します。

Canonical HTML: <https://www.de-decompiler.com/help/jp/opening_file.htm>

## ファイルを開く

対応するDelphiまたはC++BuilderのWin32/Win64向けVCLバイナリを開くには、**ファイル > プログラムを開く (File > Open program)**を選択します。

C++Builderで作成されたVCLアプリケーションも同じ方法で開きます。コンパイラ欄ではC++BuilderとFree PascalをDelphiと区別し、ツールチップでコンパイラとシグネチャデータベースの詳細を確認できます。

1. **ファイル > プログラムを開く (File > Open program)** を選択して入力ファイルを選択します。

2. プロジェクト ツリーが構築され、初期処理が完了するまで待機します。

3. 個々のプロシージャに進む前に、復元したコード構造とフォームを確認します。

### ドラッグ＆ドロップおよびコマンドラインからの開き方

Explorer からバイナリを DE Decompiler にドラッグ＆ドロップするか、コマンドラインでそのパスを渡すことができます。認識はファイルの内容に依存するため、見慣れないファイル拡張子や拡張子の欠如だけでは解析が妨げられるわけではありません。サポートされている Windows ショートカットは、参照先のファイルに解決されます。

保存された解析データベースも、ドラッグ＆ドロップまたはコマンドラインでパスを渡すことで開くことができます。複数のビルドを扱う際は、パスとファイルのバージョンが明確であることを確認してください。

### 初期解析のキャンセル

大きなアプリケーションの読み込み、クラス検出、フォーム読み取り、全プロシージャの逆コンパイル時のキャンセルを改善しました。キャンセル要求後は以降のプロシージャ処理を停止します。全体逆コンパイルをキャンセルした場合、不完全な結果は破棄します。

任意のプロトタイプ解析をキャンセルしても、解析済みファイルは開いたままとし、検出済みのプロトタイプ、API、文字列を保持します。未完了の解析レポートは表示せず、中断後はデコード設定を復元します。

### 認識に制限のある入力

利用可能な命令とメタデータは、復元された名前、型、呼び出しの詳細さを決定します。コンパイラの差異、異常な型情報、保護、およびファイルの損傷は認識に影響を与える可能性があります。予期しない結果については機械語命令ビューで確認してください。[コンパイラの互換性とRTTI](https://www.de-decompiler.com/help/jp/compatibility.htm) および [復元されたコードの解釈方法](https://www.de-decompiler.com/help/jp/validation.htm) を参照してください。

再現性のある解析を行うには、正確なバイナリを保持し、使用した設定を記録してください。同じファイル名を持つ後のビルドでは、アドレス、レイアウト、動作が異なる場合があります。
