難読化
内蔵の難読化ツールは、Delphiで記述された、またはC++Builderで作成されたWin32/Win64向けVCLアプリケーションに対応します。
この手順は、対応するC++BuilderのWin32/Win64向けVCLアプリケーションにも適用されます。
自身が開発した対応VCLアプリケーションを配布する際に難読化を利用します。この処理はコンパイル済みバイナリを変更します。復元したPascalコードの出力とは別の操作です。
アプリケーションの難読化
- 元のコンパイル済みアプリケーションを保持し、別のコピーに対して作業を行ってください。
- ファイル > プログラムを開く (File > Open program)を通じてアプリケーションを開きます。
- ツール > プロジェクトを難読化 (Tools > Obfuscate project) を選択し、出力ダイアログの指示に従ってください。
- この操作は、書き込み前にネイティブ入力をバックアップし、保存後に復元したモデルを再構築します。変換、書き込み、または再読み込みに失敗した場合、元のファイルとモデルの復元を試みます。復元が完了できない場合は、復元用コピーのパスを報告します。結果得られたアプリケーションは、その intended なデプロイメントで使用されるコンポーネント、データ、およびワークフローでテストしてください。
結果の確認
リリース記録において、元のビルドと難読化されたビルドを区別できるようにしてください。結果得られたアプリケーションにおいて、フォームの作成、コンポーネント間の相互作用、およびイベント駆動型の動作を確認します。難読化は解析を困難にしますが、プログラムが検査や逆コンパイルの対象にならないことを保証するものではありません。